[Orca-users] Re: only some rrd's getting updated [FIXED]

msapsara msapsara at yahoo.com
Mon Apr 29 07:49:17 PDT 2002

Thank you for your response.  I added "reopen 1"  to my
cfg file in the appropriate place, but I don't think that
fixed it.  I was still getting the following error:
Odd number of elements in hash assignment at /path/SourceFile.pm line 876, <FD> chunk 2.

I then went back to a saved orcallator.cfg file, fired it up,
and orca produced all the missing rrds.  The diffs show where
I commented out plots that I did not want to see, and where I
had switched the GeoCities image with a <B></B> empty tag in the
two orcallator.cfg files. 
Looks like commenting out the plots was where I went wrong ?

It's working fine now.

--- In orca-users at y..., Blair Zajac <blair at o...> wrote:
> msapsara wrote:
> >
> > I've been running Orca for a week or so, with multiple hosts, and
> > sometime this week I noticed that only some of the rrd's were being> > updated, and it was the sames ones on for each host (cpu, run queue,
> > number of processes).  Before that, all rrd's were in sync.  Once I
> > got the collection process started from remote hosts, I have not made
> > any changes, so I'm perplexed.
> >
> > When I run the orca script I see many errors of this type:
> > /orca: internal error: expecting RRD name
> > orcallator_ketchup_counter_v2writes' but no data loaded from
> > `/nfs/home/orca/orcallator/ketchup/percol-2002-04-26-001' at time Fri
> > Apr 26 11:15:01 2002 (1019834101).
> >
> > I am using rsync on the orca host to pull the percol files from the
> > orcallator hosts, and they are current.
> Because you are using rsync, you may want to add the line
> reopen 1
> inside your group orcallator { }.
> Let me know if this works.
> Also, can you send the output from orca -v up to and including the first
> several errors.
> Best,
> Blair
> --
> Blair Zajac <blair at o...>
> Web and OS performance plots - http://www.orcaware.com/orca/

More information about the Orca-users mailing list