[Orca-users] as: Value too large for defined data type

Cockcroft, Adrian acockcroft at ebay.com
Wed Apr 27 13:33:25 PDT 2005

This isn't a message from SE, so a new version won't help. It's the
startup script for orca calling "ps".
The "as" in the error message is Address Space, which is one of the
entries in the proc structure. It has nothing to do with the "as"
assembler command.

It may be that a 32bit "ps" command is encountering a 64bit address
space and can't cope with it. Its likely that /usr/ucb/ps would be
different to /usr/bin/ps as described by Mark Stoltzfus.


-----Original Message-----
From: orca-users-bounces+acockcroft=ebay.com at orcaware.com
[mailto:orca-users-bounces+acockcroft=ebay.com at orcaware.com] On Behalf
Of Blair Zajac
Sent: Wednesday, April 27, 2005 12:42 PM
To: Woolway, Philip
Cc: 'orca-users at orcaware.com'
Subject: Re: [Orca-users] as: Value too large for defined data type

Woolway, Philip wrote:

>When I run start_orcallator on Solaris 8 system I receive the following
>error. I have tried using /usr/local/bin/as and /usr/ccs/bin/as but no
>ps: read() on /proc/24679/as: Value too large for defined data type
>A quick "you didn't do this" would be appreciated.
Which version of SE are you using?  You may want to try the latest SE 
version, available at



Blair Zajac <blair at orcaware.com>
Subversion and Orca training and consulting

Orca-users mailing list
Orca-users at orcaware.com

More information about the Orca-users mailing list