[Orca-users] Installation of setoolkit-3.5.1 failing.

McMullan, James D James.D.McMullan at xo.com
Fri Mar 29 07:38:20 PDT 2013

Does anyone know of a work-around for this issue? I really need to get Orca up and running on my Solaris 11.1 servers.


From: Dagobert Michelsen [mailto:dam at baltic-online.de]
Sent: Thursday, March 28, 2013 7:59 AM
To: Martin, Jeff
Cc: Hudes, Dana; McMullan, James D; orca-users at orcaware.com
Subject: Re: [Orca-users] Installation of setoolkit-3.5.1 failing.

Hi folks,

Am 28.03.2013 um 03:47 schrieb "Martin, Jeff" <Jeff.Martin at tais.toshiba.com<mailto:Jeff.Martin at tais.toshiba.com>>:
Solaris 10 works fine, just tried Solaris 11 and got the perl cc error.
installing Sun Studio and will see the results.

The following headers are no longer available on Solaris 11 as cachefs has been dropped:

"kstat.c", line 28: cannot find include file: <sys/vmmeter.h>
"kstat.c", line 29: cannot find include file: <sys/fs/cachefs_fs.h>
"kstat.c", line 30: cannot find include file: <sys/fs/cachefs_fscache.h>

I guess a few more autoconf-tests are needed for shielding these.

Best regards

  -- Dago

From: Orca-users [mailto:orca-users-bounces+jeff.martin=tais.toshiba.com at orcaware.com<mailto:users-bounces+jeff.martin=tais.toshiba.com at orcaware.com>] On Behalf OfHudes, Dana
Sent: Wednesday, March 27, 2013 5:22 PM
To: 'James.D.McMullan at xo.com<mailto:James.D.McMullan at xo.com>'; 'orca-users at orcaware.com<mailto:orca-users at orcaware.com>'
Subject: Re: [Orca-users] Installation of setoolkit-3.5.1 failing.

I used the OpenCSW build for Solaris 10. It installs but orcalltor crashes after awhile. The service restarts it but it fails too often. I haven't had time to try to build it.

From: Orca-users <orca-users-bounces+hudesd=hra.nyc.gov at orcaware.com<mailto:orca-users-bounces+hudesd=hra.nyc.gov at orcaware.com>>
To: orca-users at orcaware.com<mailto:orca-users at orcaware.com> <orca-users at orcaware.com<mailto:orca-users at orcaware.com>>
Sent: Wed Mar 27 10:26:21 2013
Subject: [Orca-users] Installation of setoolkit-3.5.1 failing.

I need this installed to get Orca to work on Solaris 11.1

Has anyone tried to install this with success? The configure works fine but when I run a "make all"

It fails on missing /usr/include/sys* files.

kstat.c:28:25: fatal error: sys/vmmeter.h: No such file or directory

I have headers installed:

root at pladnaprd01:/opt/setoolkit-3.5.1#<mailto:root at pladnaprd01:/opt/setoolkit-3.5.1#> pkg info system/header
          Name: system/header
       Summary: Core C/C++ header files
      Category: System/Core
         State: Installed
     Publisher: solaris
       Version: 0.5.11
Build Release: 5.11
Packaging Date: January  2, 2013 07:28:09 PM
          Size: 11.09 MB
          FMRI: pkg://solaris/system/header@0.5.11,5.11-

James D. McMullan

Unix Admin
o  972-578-6892
c  469-263-3427

This message may contain confidential information. If you are not the intended recipient of this e-mail, do not disseminate, distribute or copy this e-mail and delete this e-mail from your system._______________________________________________
Orca-users mailing list
Orca-users at orcaware.com<mailto:Orca-users at orcaware.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/orca-users/attachments/20130329/31730b72/attachment.html>

More information about the Orca-users mailing list