[Orca-users] Data not showing up on graph

Jeff Brickley jbrickley at eps.sps.mot.com
Mon Aug 20 07:57:51 PDT 2001

Hello.  Hopefully this won't sound too naive but....I'm trying to get
Orca 0.26 to graph arbitrary points from a text file.  I am not having
any luck.  This is supposed to be a first 'test' to make sure we can
rely on the graphing tool. Eventually I will be producing text files
with various pieces of info that we want graphed.  This tool sounds like
the best product for what we want to accomplish but it is a bit
frustrating right now. I will detail most of what I have done thus far.
I have a test input file with the following format:
997733286 92.1064
997733586 287.747
997733886 72.1448

My config file is as follows:
state_file  test.state
html_dir  /usr1/orca/orca-0.26/html
rrd_dir   /usr1/orca/orca-0.26/var/orca/rrd

group test_group {
find_files  /usr1/orca/orca-0.26/bin/test_data.txt
column_description date AVG
date_source column_name date
date_format  %m/%d/%y
interval  300

plot {
title   MyFirstPlot
source   test_group
data   AVG
legend   Machine
y_legend  Average
data_min  0
data_max  10

I run the following command:
orca -v -o test.cfg

Everything seems to work fine and the output is as follows:
Orca version 0.26beta1 using RRDs version 1.000131.
Loading state from `test.state'.
Creating orca.gif.
Creating rrdtool.gif.
Finding files and setting up data structures at Fri Aug 17 13:45:06
3848 4648  0.4        0:00     root   382 /usr/bin/perl
Current running time is 0:00 minutes.
Loading new data.
  Read     4 data points from `/usr1/orca/orca-0.26/bin/test_data.txt'.
Flushing new data and updating PNGs.
  Creating RRD `/usr1/orca/orca-0.26/var/orca/rrd/test_group_AVG.rrd'.
Saving state into `test.state'.
Updating PNGs.
Creating HTML files in `/usr1/orca/orca-0.26/html/'.
4504 5112  0.5        0:01     root   382 /usr/bin/perl
Current running time is 0:02 minutes.

I have added the text from the uninitialized-array-patch.txt to the
orca.pl file in the prefix /src directory.
It seems that the data is not making it into the .rrd file that is being
generated.  I run the following rrdtool command and notice that all
entries have a timestamp and then NaN for the second column.
rrdtool fetch file.rrd AVERAGE

Any help anyone can give will be greatly appreciated.

More information about the Orca-users mailing list