[Orca-users] Problem creating a new plot

Darren Dunham ddunham at taos.com
Tue Jun 18 16:03:45 PDT 2002

I'm trying to massage some Windows performance data into orca.

Currently I have some machines creating this as their data.

timestamp [...] /Processor-_Total-/%_Processor_Time

And the orcallator.cfg plots it like this..

plot {
title                   %g CPU Usage
source                  windows
data                    /Processor-_Total-/%_Processor_Time
line_type               area
color                   ff0000
legend                  CPU Utilization

My new machines (but running an older OS) don't total up the time, but
instead give me individual CPU reports like this...

timestamp [...] /Processor-0-/%_Processor_Time

So I tried simply modifying the orcallator.cfg and copying that plot
down to several others.  Here's the first.

plot {
title                   %g CPU 0 Usage
source                  windows
data                    /Processor-_0-/%_Processor_Time
line_type               area
color                   ff0000
legend                  CPU0 Utilization

But I think something's wrong when I run the orcallator..  (yes, yes,
it's an older version.  I'm *trying* to upgrade it, but I keep running
out of RAM with the new version...  that's another topic...)

../bin/orca -o -v -v windows2.cfg
Orca version 0.263 using RRDs version 1.000331 at Tue Jun 18 16:00:13 2002.
Loading state from `/usr/local/orca/var/orca/rrd/windows2/windows.state'.
Creating orca.gif.
Creating rrdtool.gif.
Finding files and setting up data structures at Tue Jun 18 16:00:13 2002.
../bin/orca: warning: no substitutions performed for `data /Processor-_0-/%_Processor_Time' in plot #2 in `/usr/local/orca/var/orca/windows/ntapp14/data'.
../bin/orca: warning: cannot compile `sub { /Processor-_0-/%_Processor_Time }' for plot #2 `data /Processor-_0-/%_Processor_Time': Operator or semicolon missing before %_Processor_Time at (eval 9) line 1.

Basically, I'm worried about the "cannot compile sub.." bit.  Sure
enough, my new plots do not appear.

I don't know why this would be a syntax issue.  It seems that all I've
done is swap a '0' for a 'Total'.  Any ideas?
Darren Dunham                                           ddunham at taos.com
Unix System Administrator                    Taos - The SysAdmin Company
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

More information about the Orca-users mailing list