[Orca-users] Orcallator - Segmentation Fault

Dmitry Berezin dberezin at surfside.rutgers.edu
Thu Sep 7 08:42:32 PDT 2006


I believe that the actual problem is not with the array sizes, but has to do
with the "stale" disk devices. SE "segfaults" when it tries to access a
device that is not currently present on the system. That is why the problem
is usually seen on the clustered systems with shared storage or systems with
BCV devices that frequently change their state to offline. A number of
people had previously reported that rebuilding device tree fixed the

I have not had time to look at the code, so I do not know if this could be
solved by changing scripts or SE itself has to be patched.


> -----Original Message-----
> From: orca-users-bounces+dberezin=acs.rutgers.edu at orcaware.com
> [mailto:orca-users-bounces+dberezin=acs.rutgers.edu at orcaware.com] On
> Behalf Of Cockcroft, Adrian
> Sent: Thursday, September 07, 2006 11:13 AM
> To: Biju Joseph; orca-users at orcaware.com
> Subject: Re: [Orca-users] Orcallator - Segmentation Fault
> Years ago I fixed the code that looks at disks to resize the array
> dynamically, I guess that this code got overwritten at some point, but its
> a simple fix, just doesn't look much like C code...
> You can use the "renew" keyword to make a new array that is bigger and
> contains the same items, so figure out where its indexing into the disk
> array, check the index and renew the array to be size+10 or something.
> There's example code in the generic SE disk class, which for some reason
> orcallator doesn't seem to use?
> I'm not currently working on a Solaris box, so it will take me a while to
> get a setup I could test this fix on, probably a few weeks when I get back
> from a business trip.
> Adrian
> -----Original Message-----
> From: orca-users-bounces+acockcroft=ebay.com at orcaware.com on behalf of
> Biju Joseph
> Sent: Thu 9/7/2006 7:28 AM
> To: orca-users at orcaware.com
> Subject: [Orca-users] Orcallator - Segmentation Fault
> Hello All,
> I am trying to start orcallator on two nodes of VCS cluster ( 4.1 ) with
> VxVM 4.1 . Database is on EMC disks. Orcallator is giving segmentation
> fault.
> RICHPse version is 3.4 (03:59 PM 01/05/05).  I tried using orcallator.se
> 1.36 and 1.37. Both giving same problem.
> The same combination is working on non clustered systems. All systems are
> Solaris 10
> Can any of you help.
> Appreciate your help.
> Regards
> Biju K Joseph
> +91-9866116298
> _______________________________________________
> Orca-users mailing list
> Orca-users at orcaware.com
> http://www.orcaware.com/mailman/listinfo/orca-users

More information about the Orca-users mailing list