[Orca-users] URL problems with certain graphs?

Jon Tankersley jon.tankersley at eds.com
Mon Aug 9 10:59:01 PDT 2004

run orca -o -v -v -v -v orcallator.cfg 
with clean directory paths and a sample data.
It looks like the plot pattern match is not doing what it should.
I'm not sure if it is eval'd properly, Blair can probably answer that.
Of course, you COULD just use
depending  on your data.
Our systems use:
data                    disk_runp_(c\d+t\d+d\d+)

-----Original Message-----
From: orca-users-bounces+jon.tankersley=eds.com at orcaware.com
[mailto:orca-users-bounces+jon.tankersley=eds.com at orcaware.com] On Behalf Of
Joel D. Cohen
Sent: Monday, August 09, 2004 12:43 PM
To: David Michaels
Cc: orca-users at orcaware.com
Subject: Re: [Orca-users] URL problems with certain graphs?

I'm sure it has to do with the file name, but how can I fix it? I can browse
to those files by manually searching that directory for images, but that's
not really acceptable. I'm using Apache 2.0.49 with mod_jk2/2.0.2 and
PHP/4.3.7 (it's a multipurpose web server)

My orcallator.cfg is where this is getting generated, no?

plot {
title                   %g Disk Run Percent
source                  orcallator
line_type               line2
legend                  $1
y_legend                Run Percent
data_min                0
data_max                100
plot_min                0

This is the default from my build of Orca.

Joel Cohen
System Administrator
Davis, Polk & Wardwell

At 11:16 AM 8/9/2004 -0600, David Michaels wrote:

I think it doesn't like those files because of the %[number] combinations,
actually.  I believe %## is interpreted on the web server side as a special
character.  For instance, oftentimes you'll see %20 in the URL where a space
is in the desired filename.

To try and reproduce your error, I renamed one of my test html files to
match your original filename, which I figure to be something like this:


(replaced the png extension with html), and was able to load it up in
Mozilla 1.7, IE 6.0, and FireFox 0.9.  To access the file, since it had such
a long name, I browsed to the parent directory (browse-contents turned on at
the Apache server level), then clicked on the link for the file, and it
worked like a charm in all 3 cases, but only because the web browser
translated the \'s, |'s, ?'s, and []'s into % replacements.  However, when I
tried to be more explicit about the URL by cut&pasting the /actual/ filename
into the URL field (after the parent URL, of cuorse), it failed with a 

404:  "The requested URL
/~dmichael/citrix/o_prd20_gauge_volatile_disk_runp_(( was not found on this

Note the lack of any characters in the filename past the ?.  That's because
the ? is a special character, used with CGI scripts and the like.

Here's how the webserver translated your filename so it would be browsable:


This should pretty much match what you had in your URL.  All 3 of my
browsers were able to browse the above filename, using Apache on the server

Many of my files have this syntax in them (with ?'s and \'s and the like),
and I have no problem browsing to any of them.  What error do you get when
you try to browse to that URL?


Joel D. Cohen wrote:

Hi all,

I've got a problem with IE and Firefox not being able to show some graph

images because the URL for them has weird characters in it. Here is an

example of one graph that is not showing up:


My guess is that it's because of the \ characters. Anyone else run into

this and know how to fix it?

I'm running Orca 0.28 dev 380 on Solaris 8.

Joel Cohen

System Administrator

Davis, Polk & Wardwell


Orca-users mailing list

Orca-users at orcaware.com





David P. Michaels
Senior Multi-Disciplined Engineer II W.H.
Platform OS Unix
720.858.5952 fax
720.521.0561 pager
dragon at raytheon.com aka "Dragon" 

"I wonder what news is doing..."

 news at newshost <29> ps -fu news      

 news 18624 12367 2 0:00 makehistory 

"News is making history."


-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/orca-users/attachments/20040809/2b8ec3f4/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 6b3941c.gif
Type: image/gif
Size: 481 bytes
Desc: not available
URL: </pipermail/orca-users/attachments/20040809/2b8ec3f4/attachment.gif>

More information about the Orca-users mailing list