[Orca-users] procallator question

Matthew Boeckman matthewb at saepio.com
Thu May 11 07:02:16 PDT 2006

FWIW - I cannot get the snapshot to compile on RHEL WS under any of the
following platforms/kernels: (x86_64, 2.6.9-22... x86, 2.4.21-4).

I really want it working on my 64bit boxen, so I'll just ask after that:

x86_64 AMD64 2.6.9-22
(fails : gcc  -shared RRDs.o -L../src/.libs/ -lrrd_private   -lm -o
/usr/bin/ld: ../src/.libs//librrd_private.a(parsetime.o): relocation
R_X86_64_32 against `a local symbol' can not be used when making a
shared object; recompile with -fPIC
../src/.libs//librrd_private.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[5]: *** [blib/arch/auto/RRDs/RRDs.so] Error 1
make[5]: Leaving directory
make[4]: *** [perl_shared] Error 2
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [all] Error 2
make[2]: Leaving directory
) - adding -fPIC doesn't change anything

Would it be possible to get --disable-blah options to configure with
orca? As I mentioned in my original post I've used it for years, and
seems like I always have trouble with the stuff you guys put in the
packages directory. In the past I can get around it by pulling those
packages (RRD, MD5, Time, etc) separately, and just beating my head
against it for a few hours.

I've tried --with-rrd=(my valid, working rrd install path), 
--with-rrdtool=same --without-rrd --without-rrdtool, etc etc and make 
continues to fail.

Does the build just obstinately ignore the options I pass it, or am I 
doing something painfully wrong?


Matthew Boeckman
Manager - Systems Integration
Saepio Technologies, Inc.

Cynthia Kiser wrote:
> Yes procallator is still being developed - and I am pretty sure now
> has stuff to make it compatible with the changes to /proc made in the
> linux 2.6 kernels. Install the latest subversion snapshot. Despite the
> name, it's stable.
> Blair, this comes up a lot and the answer is always, install the
> snapshot. Should the web site really be telling folks that 0.27 is the
> "latest stable"? As far as I can tell, the subversion snapshots are
> pretty stable. The only issues I recall having seen on the list are
> things that would be equally problematic in 0.27 and the subversion
> version (e.g. Solaris systems with disks coming and going
> dynamically).
> Quoting Matthew Boeckman <matthewb at saepio.com>:
>> Hi! This may be more appropriate for the orca-devel list, but I thought 
>> I'd start here.
>> Is procallator still being actively developed? I recently tried to use 
>> it in some x86_64 (AMD64) boxes running 2.6.9-22 (RHEL) and it looks 
>> like the disk reporting stuff in proc changed, again. I'm also not 
>> seeing statistics on swap and mem usage getting recorded.
>> I guess I'm curious if there is an updated procallator someone can point 
>> me to (using the one provided in orca-0.27)? Anyone else running 
>> procallator on 2.6?
>> Thanks!
>> -- 
>> Matthew Boeckman
>> Manager - Systems Integration
>> Saepio Technologies, Inc.
>> 816-777-2160
>> _______________________________________________
>> Orca-users mailing list
>> Orca-users at orcaware.com
>> http://www.orcaware.com/mailman/listinfo/orca-users

More information about the Orca-users mailing list